USB Indexing Failure - FIXED!!

Frequently Asked Questions
Post Reply
Posts: 1586
Joined: Sun Mar 23, 2014 9:45 pm

USB Indexing Failure - FIXED!!

Post by duncho » Mon Dec 07, 2015 9:49 pm

I spent so much time on trying to fix USB files indexing always crashing on 71% with no luck whatsoever. NISSAN doesn't care as they sold the car, so why should they bother... unexperienced CS staff lacking of technical knowledge was waste of time and nerves..

GOOD NEWS, there is an easy fix which solves this annoying Nissan Connect bug!

The issue is caused by pen drive file format other than FAT32. NTFS or exFAT file format is recognized by Connect, but file indexing will always fail on 71%.

Microsoft Windows won't let you to format your pen drive to FAT32 if bigger than 32GB, but there is a hope. I found pretty neat tool by which you can easily format any size flash drive to FAT32. Download here: ... format.htm run as admin, select your pen drive or SSD from the drop down menu and click format. I used default 32768kb cluster size which works perfectly! No more issues and clipping while listening audio files with higher bit rate due to Connect being busy with file indexing ;)


FAT32 formatting tool
Qashqai J11, 1.6 dCi CVT, ThermaClear

For latest news & tests Subscribe! to my Image
Get your Stop/Start reversing & DRL dim/OFF modules here: Image

User avatar
Posts: 3010
Joined: Thu May 22, 2014 12:02 pm
Location: Thames Valley UK
Qashqai Model: Mk.2 Qashqai - J11 (2013–2017)

Re: USB Indexing Failure - FIXED!!

Post by Gel » Tue Dec 08, 2015 8:17 am

So you reckon that'd be OK with 64gb drive then Dan too?
2014-19 J11A-14 1.5dci Ink Blue Tekna owner; now departed for a Mazda CX-5 GT Sport Nav, 2.0L Petrol :D

User avatar
Posts: 1171
Joined: Sat Jan 25, 2014 5:25 pm

Re: USB Indexing Failure - FIXED!!

Post by jonceebee » Tue Dec 08, 2015 9:10 am

Yes Dan is correct this is the solution, I discovered this a while ago when I changed to a 64gb USB pen. They are normally formatted to ex-Fat which causes the indexing problems. The link Dan provided will allow you to format to FAT and the indexing problems will go away.

Here are the full instructions:

Note If you find fat32format a bit fiddly to use or these instructions a bit hard to follow you should try the replacement for fat32format. It is a Windows application with a GUI. Try it here

I recently got a SATA 250GB disk for testing FATLIB. It turns out that Windows XP won't let you format a volume bigger than 32GB with FAT32. I could use NTFS, but that's not what I FATlib supports. In fact, NTFS can only be written safely by Windows XP - there are as far as I know no other drivers for other OS's, unlike FAT which is supported by virtually anything.

As Microsoft put it here

You cannot format a volume larger than 32 gigabytes (GB) in size using the FAT32 file system during the Windows XP installation process. Windows XP can mount and support FAT32 volumes larger than 32 GB (subject to the other limits), but you cannot create a FAT32 volume larger than 32 GB by using the Format tool during Setup. If you need to format a volume that is larger than 32 GB, use the NTFS file system to format it. Another option is to start from a Microsoft Windows 98 or Microsoft Windows Millennium Edition (Me) Startup disk and use the Format tool included on the disk.

Using Windows 98 obviously opens up other issues - It doesn't support USB 2.0 or SATA as far as I know. Formatting a huge disk will take ages. It suports IDE, but not 48bit LBA, which is required for drives greater than 137GB. Also, you need to patch format.exe and fdisk to work with disks greater than 64GB. Even then scandisk will corrupt large disks unless you disable it. It can be done, but basically, this is ancient 16 bit code, and using it on modern hardware is not a good idea. There is a port of mkdosfs from Linux to Win32. I tried it, and chkdsk complained about being unable to test a RAW filesystem. It also uses funny cluster sizes, only 4K for normal sized disks.

Actually, looking back at the Microsoft comment, if I could format the volume myself, all would be OK. Fat32 is pretty simple, so it occured to me to write a fast format routine to do the job. Note that the 32GB limit is a limit of the formatter in Windows XP. FAT32 itselft should be OK to 2TB, limited by a 32 bit sector count in the boot sector. XP comes with a partitioning tool, called Disk Management. It even has Wizards for partitoning. This should be a cinch.

I've tested this with a SATA disk as follows. Power off the computer and connect the disk. Power up again - check the Bios finds it. If you have a IDE or SATA disk, make sure you power off before connecting, USB and Firewire ones can be connected with the power on.

Click Start menu, select Run and enter diskmgmt.msc

If it asks you to initialise the disk, make sure you select a Basic disk, as opposed to a Dynamic.
There's a guide on Disk Management here You need to find the disk with unallocated space. Right click on it and select "New Partition" and follow these steps, clicking "Next" to get move on at each stage. 1.Partition Wizard starts, just click next to move on
2.Select Primary Partition.
3.Enter the maximum size for the Partition Size
4.Choose assign a drive letter. I used F:
5.Select "Do not Format this partition"
6.There will be a dialog box, summarising all the previous stuff. Click Finish

Now you have a drive letter, this is what we will pass to the formatter

Now download a copy of fat32format. Extract the single EXE file to somewhere suitable, like C:\.

Click Start->Run and enter

When the command prompt opens, type this - C:\ is the place you extracted the exe file to. Note if this sort of command line stuff makes your head hurt, you should probably give this a try instead
CD /D C:\

press enter and then type this. You need to replace f: with the drive letter you are trying to format.
fat32format f:

You should see this displayed
Warning ALL data on drive 'f' will be lost irretrievably, are you sure (y/n)

Now when it says this, it really means it. If you format the boot sector, FATs and root directory will be filled with zeros. By typing pressing Y and hitting return, you're also absolving me of liability for whatever was on the disk before.

Assuming you don't bail out at this point you should see something like this -
Warning ALL data on drive 'f' will be lost irretrievably, are you sure
(y/n) :y
Size : 250GB 488392002 sectors
512 Bytes Per Sector, Cluster size 32768 bytes
Volume ID is 1bdb:2c1d
32 Reserved Sectors, 59604 Sectors per FAT, 2 fats
7629261 Total clusters
7629260 Free Clusters
Formatting drive f:...
Clearing out 119304 sectors for Reserved sectors, fats and root cluster...
Wrote 61083648 bytes in 0.988463 seconds, 61796609.106193 bytes/sec
Initialising reserved sectors and FATs...

This means that all has gone according to plan. It should take about 4 seconds per Terabyte to format the disk. You can run chkdsk f: at this point if you're curious, and see something like this -
The type of the file system is FAT32.
Volume Serial Number is 1BDB-2C1D
Windows is verifying files and folders...
File and folder verification is complete.
Windows has checked the file system and found no problems.
244,136,352 KB total disk space.
244,136,320 KB are available.

32,768 bytes in each allocation unit.
7,629,261 total allocation units on disk.
7,629,260 allocation units available on disk.

This shows that my calculations match up with the ones inside Windows, which is good news

It is also possible to set the cluster size with a -cN parameter where N is the number of sectors per cluster. On a hard disk, which is the only sort we support, one sector is 512 bytes. The cluster size will be N times 512. I played around with this, and it seems that Windows XP supports small cluster sizes, except that chkdsk runs very slowly, presumably because it needs to read the huge FAT that results from these settings. Given the nature of FAT32, you can't reduce the cluster size such that the number of clusters is more than 228. I'd recommend using the default cluster sizes, which are the Microsoft recommended ones, unless you need to force them for testing or something

You can download either just the fat32format binary ~20K or the fat32format binary and source ~30K The source code can be compiled with Vistual Studio 6.0 or later. The current version number is 1.01.
QQ 2014 1.2 Tekna Storm White. Chromed front lip finisher,Side Sills,Glass Finisher, Lower Trunk Finisher, White Side mouldings, White AlloyGaytors, Wind Deflectors
Cross Over Pack, auto fold mirrors

Posts: 1586
Joined: Sun Mar 23, 2014 9:45 pm

Re: USB Indexing Failure - FIXED!!

Post by duncho » Tue Dec 08, 2015 9:13 am

I believe so, as it works on my 128GB drive. I have 64GB ultra fit 64GB SanDisk drive ... 6820173035 so I can test it for you. I just need to copy all data out of it.
Qashqai J11, 1.6 dCi CVT, ThermaClear

For latest news & tests Subscribe! to my Image
Get your Stop/Start reversing & DRL dim/OFF modules here: Image

fat controller
Posts: 190
Joined: Tue Aug 25, 2015 7:22 pm

Re: USB Indexing Failure - FIXED!!

Post by fat controller » Tue Dec 08, 2015 8:20 pm

This is great! Thank you :)

Can this be made a sticky please?

The majority of my MP3 files are at higher bit rates, and clipping is a real pain in the neck - seems to be worse if the Sat-Nav is busy with traffic info, which made me wonder if the problem was a lack of system memory.

And the news that 128Gb chip can be made to work really is music to my ears ('scuse the pun) as that will allow me even more variety :)
1.5dci Acenta Premium
Wishlist: Autofold Mirrors, Chrome body trim and Metal sill protectors;


Posts: 28
Joined: Wed Jun 25, 2014 4:49 pm

Re: USB Indexing Failure - FIXED!!

Post by orlando » Sat Jan 20, 2018 1:52 pm

I've been struggling with this and finding this fix seemed perfect, but, I tried using the formatting tool to set the USB stick (125 gb) to Fat 32 but it isn't recognised at all by my 2014 Qashqai. I can however get it recognising an NTFS formatted drive. I have a 1 TB Western Digital HDD that it recognises even though I do have an indexing problem with that too. I now don't know whether the problem is car specific or device specific, any help would be most welcome.


Post Reply