Display doesn't works

ICE, Equipment, Options
Post Reply
Sprm
Posts: 1
Joined: Sat Jan 05, 2019 8:40 pm
Qashqai Model: Mk.1 Qashqai - J10 (2006–2013)

Display doesn't works

Post by Sprm » Sat Jan 05, 2019 9:31 pm

Hi all,
The radio display on my J10 2011 does not work. The radio and other functions work completely but the display sometimes stops working. Do you know any solution to solve this issue?
Attached is a photo to identify the radio.

Thanks in advance.

post-3410-12973402180636.jpg



mskayaker1951
Posts: 1
Joined: Wed Mar 13, 2019 10:44 am
Qashqai Model: Mk.1 Qashqai Facelift - J10b (2010–2013)

Re: Display doesn't works

Post by mskayaker1951 » Tue May 14, 2019 8:14 pm

Hi I bought my 2010 QQ J10 from a local dealer in January & its been back to Nissan garage for a few faults since which have all been rectified. But it also has the annoying fault of the radio display disappearing after a while in use. I complained to the dealer who replaced it ( obviously second hand ). Now I have two radios both with displays vanishing. I did see somewhere on a forum to disconnect the front panel & clean contact points. Did this to no avail.


User avatar
calnorth
Posts: 230
Joined: Mon Feb 11, 2019 2:01 pm
Qashqai Model: Mk.2 Qashqai Facelift - J11b (2017–present)

Re: Display doesn't works

Post by calnorth » Wed May 15, 2019 7:29 am

That display is a complete circuit board I think....some of them will suffer breaks in soldering and/or connector tracks. Shouldn't think there is much in the way of quality about them.

I'd have that board off and run a soldering iron around its tracks etc ...if it looked able to stand that?
Thankfully unbusy (retired)
Mk2 Qashqai Facelift - J11b (2017–present)
1.6 Dig-T N-Connecta


Post Reply

Return to “Electronic systems”