Issues with USB

ICE, Equipment, Options
Skawars86
Posts: 11
Joined: Sat Aug 03, 2019 4:18 pm
Qashqai Model: Mk.2 Qashqai - J11 (2013–2017)

Issues with USB

Post by Skawars86 » Thu Jul 30, 2020 11:23 am

So my 2019 Model was working fine connected to my Galaxy S20, using android auto for maps/music/whatapp etc. One day it just randomly stopped working.

When I plug it in via usb at first it says 1h to fully charge, then a second later goes to something ridiculous like 20 hours to fully charge. On the connections screen it doesn't show any usb connected.

When i took it in to the nissan dealership they said they couldnt see the issue but I know they didnt test properly. I have tested 3 different phones and 4 different usb cables. I have factory reset the phone and the car system.

I have downloaded and updated the maps, when I connect to wifi to download the system update it just stays on "downloading..." no progress bars or anything.

I'm thinking it might be a loose connection somewhere? Is it possible for me to have a look at the wiring? The only thing I can think of is maybe they messed around with something when fitting my black box- however that was back in September and the issue only arose a month or so ago. Just annoying not being able to use all these features!

andy2019
Posts: 200
Joined: Sat Oct 26, 2019 8:47 pm
Qashqai Model: Mk.2 Qashqai - J11 (2013–2017)

Re: Issues with USB

Post by andy2019 » Thu Jul 30, 2020 11:49 am

have you tried another usb port to plug it into

User avatar
calnorth
Posts: 1407
Joined: Mon Feb 11, 2019 2:01 pm
Qashqai Model: Mk.2 Qashqai Facelift - J11b (2017–present)

Re: Issues with USB

Post by calnorth » Thu Jul 30, 2020 12:00 pm

Can we assume your Galaxy phone works with a PC and house Router in all usual respects?
Thankfully unbusy (retired)
Mk2 Qashqai Facelift - J11b (2017–present)
1.6 Dig-T N-Connecta

Skawars86
Posts: 11
Joined: Sat Aug 03, 2019 4:18 pm
Qashqai Model: Mk.2 Qashqai - J11 (2013–2017)

Re: Issues with USB

Post by Skawars86 » Thu Jul 30, 2020 12:07 pm

Correct, I just tested it now to double check

User avatar
calnorth
Posts: 1407
Joined: Mon Feb 11, 2019 2:01 pm
Qashqai Model: Mk.2 Qashqai Facelift - J11b (2017–present)

Re: Issues with USB

Post by calnorth » Thu Jul 30, 2020 12:17 pm

Skawars86 wrote:
Thu Jul 30, 2020 12:07 pm
Correct, I just tested it now to double check
Which of these Android versions is yours? If its the Google App download have you deleted it and re-installed?

"If you have Android 9 or below, get the Android Auto app on your phone.
With Android 10, Android Auto is built in – so you don’t need the app to get started".
Thankfully unbusy (retired)
Mk2 Qashqai Facelift - J11b (2017–present)
1.6 Dig-T N-Connecta

Skawars86
Posts: 11
Joined: Sat Aug 03, 2019 4:18 pm
Qashqai Model: Mk.2 Qashqai - J11 (2013–2017)

Re: Issues with USB

Post by Skawars86 » Thu Jul 30, 2020 12:29 pm

I'm on android 10. When I search for android auto in the play store it shows it as installed. I have tried uninstalling and reinstalling. In developer options on my phone, default USB connection is set as file transfer/android auto. I've tried turning USB debugging on and off.

Skawars86
Posts: 11
Joined: Sat Aug 03, 2019 4:18 pm
Qashqai Model: Mk.2 Qashqai - J11 (2013–2017)

Re: Issues with USB

Post by Skawars86 » Thu Jul 30, 2020 12:31 pm

My software version is 0814

User avatar
calnorth
Posts: 1407
Joined: Mon Feb 11, 2019 2:01 pm
Qashqai Model: Mk.2 Qashqai Facelift - J11b (2017–present)

Re: Issues with USB

Post by calnorth » Thu Jul 30, 2020 12:49 pm

Skawars86 wrote:
Thu Jul 30, 2020 12:29 pm
I'm on android 10. When I search for android auto in the play store it shows it as installed. I have tried uninstalling and reinstalling. In developer options on my phone, default USB connection is set as file transfer/android auto. I've tried turning USB debugging on and off.
I suspect Android Auto 10 is locked to the Google Apps package as whole so can't be deleted. So switch Developer options OFF unless you are off rooting or using ADB .

USB can get mixed up but I think you have the right setting there...for file transfer.

Someone says elsewhere that you have 2 USB ports in the car and you should use the one under the Climate control panel. Any other seems to be charging only? USB is usually single channel unless a USB hub exists?.
Thankfully unbusy (retired)
Mk2 Qashqai Facelift - J11b (2017–present)
1.6 Dig-T N-Connecta

Skawars86
Posts: 11
Joined: Sat Aug 03, 2019 4:18 pm
Qashqai Model: Mk.2 Qashqai - J11 (2013–2017)

Re: Issues with USB

Post by Skawars86 » Thu Jul 30, 2020 3:12 pm

I have 2 usb slots behind the drivers left armrest (for back passengers) , and one inside the armrest which I was using as the main one. All 3 give a charge but no android auto.

User avatar
MikeGC
Posts: 582
Joined: Tue Feb 07, 2017 11:50 am
Location: Stockport
Qashqai Model: Mk.2 Qashqai Facelift - J11b (2017–present)

Re: Issues with USB

Post by MikeGC » Thu Jul 30, 2020 3:35 pm

Skawars86 wrote:
Thu Jul 30, 2020 3:12 pm
I have 2 usb slots behind the drivers left armrest (for back passengers) , and one inside the armrest which I was using as the main one. All 3 give a charge but no android auto.
You probably know, but the only one which works as a USB reader or to connect your phone is the one inside the armrest/cubby
July 2019 Qashqai 1.3DIG-T 160 DCT Tekna in Vivid Blue
previous March 2017 Qashqai 1.5dci n-connecta in Gun Metal Grey
previous September 2014 Juke 1.5dci n-connecta in Gun Metal Grey

Post Reply