Constant Regeneration problems on Nissan Qashqai J10 year 2009 1.5 DCI

Forum for Engine, Exhaust, Drivetrain, ECU
Post Reply
arditkaci
Posts: 5
Joined: Sat Jan 09, 2021 4:35 pm
Qashqai Model: Mk.1 Qashqai - J10 (2006–2013)

Constant Regeneration problems on Nissan Qashqai J10 year 2009 1.5 DCI

Post by arditkaci » Sat Jan 09, 2021 7:06 pm

Sorry i am new member here. I need few help because i sent my car in many garage and they are not resolving the problem. Please i need few help for suggestion . I have nissan qashqai j10 1.5 year 2009 make constantly regeneration. i Cleaned the DPF and again after 3 days started to do regeneration. In the end i found was MAF sensor. I changed and puted new one the same thing. In the diagnostic computer show the three sensor of dpf but this i changed and after that i stacked the MAF sensor and the car work ook no problem. But when i went in the garage they said need ECU software update to work the MAF sensor . Somebody have any suggestion?? Car it work perfect with no MAF sensor and is ok only when i plug the MAF come the red check engine light and start the regeneration process every moment. When i put in diagnostic i take the codes of the 3 dpf sensor. Does need any ECM update or what i can do ???

arditkaci
Posts: 5
Joined: Sat Jan 09, 2021 4:35 pm
Qashqai Model: Mk.1 Qashqai - J10 (2006–2013)

Re: Constant Regeneration problems on Nissan Qashqai J10 year 2009 1.5 DCI

Post by arditkaci » Sat Jan 16, 2021 5:01 pm

0EC2C2CC-FBE1-4730-829A-4F607A661E43.jpeg

That was the problem with dpf battery
Case resolved to help the others was positive battery one of battery jack

Post Reply