Stop and Start System Fault

Forum for Engine, Exhaust, Drivetrain, ECU
algnerd
Posts: 32
Joined: Wed Sep 02, 2020 1:17 pm
Qashqai Model: Mk.2 Qashqai - J11 (2013–2017)

Re: Stop and Start System Fault

Post by algnerd » Fri Feb 05, 2021 1:02 pm

calnorth wrote:
Fri Feb 05, 2021 10:28 am
algnerd wrote:
Thu Feb 04, 2021 7:14 pm
calnorth wrote:
Thu Feb 04, 2021 8:47 am
Did the dealer mention anything about error codes (DTCs) they should have scanned for? You'll need to find out if such codes exist to aid diagnostics. Otherwise its mainly guess work.
They did find a p1480.

Today I changed one sensor, the p1480 disappeared and a new one related to FAP/DFP appeared and it needs to be changed too. I'll wait until Saturday to go look for it and change it.
From diagnostics: P1480 EXHAUST ELECTRIC THROTTLE CONTROL ACTUATOR

Engine Management detects performance related to exhaust and probably would disrupt Speed (Cruise/Limit) control
Faults detected:
• Exhaust throttle valve regulation error.
• ECM detects an incorrect closed position of the exhaust throttle valve.
The p1480 error eas cleared yesterday. And after a road trip of 5hours they both worked. (cruise control and speed limiter) for about 60min in total.
I did the same trip today with all electrics disabled and the stop/start did work fine.

Guess I need to change the battery and see if it is really a battery issue.
QQ Tekna 1.6 dCi

algnerd
Posts: 32
Joined: Wed Sep 02, 2020 1:17 pm
Qashqai Model: Mk.2 Qashqai - J11 (2013–2017)

Re: Stop and Start System Fault

Post by algnerd » Mon Feb 08, 2021 6:52 pm

Today, I changed what I think is the O2 Sensor (it was plugged next to the turbo -- Ref 227701177R) and still I have the same issue.
I also tried an 85Ah battery (not fitted for stop and start) still same issue.

Although, I noticed that the Speed Limiter stays on when above a certain speed (70km/h) I'll confirm this on my way to work tomorrow morning.
QQ Tekna 1.6 dCi

User avatar
calnorth
Posts: 1934
Joined: Mon Feb 11, 2019 2:01 pm
Qashqai Model: Mk.2 Qashqai Facelift - J11b (2017–present)

Re: Stop and Start System Fault

Post by calnorth » Tue Feb 09, 2021 12:12 pm

The ASCD (Cruise Control) system is managed by the ECU which in turn receives various inputs from sensors. I don't know the full input compliment and they may vary between engine types. They may have different parameter value envelopes which if breached raises DTC's and disconnects functions ...like ASCD and Stop/Start. Without accurate information per ECU its a guess work game I think.
Mk2 Qashqai Facelift - J11b (2017–present)
1.6 Dig-T N-Connecta

algnerd
Posts: 32
Joined: Wed Sep 02, 2020 1:17 pm
Qashqai Model: Mk.2 Qashqai - J11 (2013–2017)

Re: Stop and Start System Fault

Post by algnerd » Tue Feb 09, 2021 1:14 pm

I was at someone today who run a diagnostic on my car and told me that it might be because the FAP is dirty and needs to be cleaned. Once it is cleaned all systems should work properly.
What do you guys think?
QQ Tekna 1.6 dCi

algnerd
Posts: 32
Joined: Wed Sep 02, 2020 1:17 pm
Qashqai Model: Mk.2 Qashqai - J11 (2013–2017)

Re: Stop and Start System Fault

Post by algnerd » Mon Feb 15, 2021 9:49 pm

calnorth wrote:
Fri Feb 05, 2021 10:28 am
algnerd wrote:
Thu Feb 04, 2021 7:14 pm
calnorth wrote:
Thu Feb 04, 2021 8:47 am
Did the dealer mention anything about error codes (DTCs) they should have scanned for? You'll need to find out if such codes exist to aid diagnostics. Otherwise its mainly guess work.
They did find a p1480.

Today I changed one sensor, the p1480 disappeared and a new one related to FAP/DFP appeared and it needs to be changed too. I'll wait until Saturday to go look for it and change it.
From diagnostics: P1480 EXHAUST ELECTRIC THROTTLE CONTROL ACTUATOR

Engine Management detects performance related to exhaust and probably would disrupt Speed (Cruise/Limit) control
Faults detected:
• Exhaust throttle valve regulation error.
• ECM detects an incorrect closed position of the exhaust throttle valve.
After more than 15 days of checking and rechecking. It was due to ETC that wasn't in the right position. Had to cut and weld my exhaust pipe.
All systems are back to normal.
Thank you all for the help and suggestions.
QQ Tekna 1.6 dCi

Post Reply