Red Battery Light Pulsing when driving - Qashqai J11

Forum for Engine, Exhaust, Drivetrain, ECU
kavani
Posts: 9
Joined: Fri Nov 24, 2023 4:25 pm
Qashqai Model: Mk.2 Qashqai - J11 (2013–2017)

Post by kavani »

Hi All,

I really hope someone can help or share some ideas/tips if they have had similar issue.

I have a Qashqai J11 2016 1.5Dci and the Red Battery light intermittently pulses when driving and comes on for only 1 second or less. With this pulsing the Stop/Start message shows which turns off and quickly back on. This pulsing happens only few times during a 15 minute drive or does not pulse at all on most occasions. There have been few times the red battery light has stayed on for couple of minutes but is generally rare. I mainly get the red battery light pulsing few times in the mornings on a cold start but can happen at any point, even when engine fully hot on the motorway. Other than this intermittent pulsing of the red battery light the car starts and drives perfectly fine and there is no degradation in performance - also battery/alternator voltage tests have been fine.

I have had the NISSAN DEALERS replace the alternator, alternator belt, new EFB battery but I am still getting the issue. They have recently said they spotted a wire loom which was behind the battery which was rubbing on the engine mount and have taped it up. This has not helped either and still getting the issue.

What else can anyone please recommend I check physically or can ask Dealers to check next time I take it to them? Clearly everything that has been tried has not fixed the issue.

1000011920.jpg

Last edited by kavani on Thu Nov 30, 2023 6:26 pm, edited 1 time in total.

User avatar
roadster
Posts: 63
Joined: Tue Sep 05, 2023 8:37 am
Qashqai Model: Mk.3 Qashqai - J12 (2021+) New Model

Post by roadster »

It could be a genuine fault which is being detected so to eliminate that I would try to constantly monitor battery voltage from the driving position. Ideally this would be done by semi permanent wiring from the battery to a multi-meter but it might be worth trying the simpler option of an LCD monitor which plugs in to the 12v socket if that is easily viewed from the driving position. When you know whether the warning light is responding to a genuine voltage fluctuation it would help trace the problem.
kavani
Posts: 9
Joined: Fri Nov 24, 2023 4:25 pm
Qashqai Model: Mk.2 Qashqai - J11 (2013–2017)

Post by kavani »

Thanks for the advice roadster. My issue is the battery blink is so intermittent and quick (less than 1 second) that it will be impossible for me to see the voltage drop within this time.

I really need help in what common things I can clean, test, look out for or replace as looks like this issue will only be resolved with trial and error as it is very intermittent.

Many thanks!!
kavani
Posts: 9
Joined: Fri Nov 24, 2023 4:25 pm
Qashqai Model: Mk.2 Qashqai - J11 (2013–2017)

Post by kavani »

Hi everyone, quick update. I have been told when the red battery light pulses it has NOT left any error codes on the ECU that can be obtained from the Consult diagnostic scans.

Has anyone came across this before where no error codes are obtained but you have seen the red battery light come on and off within seconds?
kavani
Posts: 9
Joined: Fri Nov 24, 2023 4:25 pm
Qashqai Model: Mk.2 Qashqai - J11 (2013–2017)

Post by kavani »

Hi, anything anyone can share to help me on this one? Many thanks!!
Oliver01
Posts: 1
Joined: Thu Jan 11, 2024 2:37 pm
Qashqai Model: Mk.2 Qashqai - J11 (2013–2017)

Post by Oliver01 »

All,
I have the same issue as detailed below:
Nissan Qashqai J11 intermittent red battery and engine management light are flashing on then off no error codes when OBD read..

Any suggestions would be appreciated. Just had new battery and alternator, also OBD battery reset.

rgds
kavani
Posts: 9
Joined: Fri Nov 24, 2023 4:25 pm
Qashqai Model: Mk.2 Qashqai - J11 (2013–2017)

Post by kavani »

I am continuing to have same issue as Oliver01, any help will be much appreciated if someone has managed to resolve a similar issue and what they did.
The yellow engine management fault just states Charging Issue as read by Nissan Consult diagnostics, nothing more specific.

Oliver01 if you resolve issue please post what was done as it will help me greatly. Likewise if I resolve then will let you know.

Many thanks
kavani
Posts: 9
Joined: Fri Nov 24, 2023 4:25 pm
Qashqai Model: Mk.2 Qashqai - J11 (2013–2017)

Post by kavani »

Any suggestions from anyone?? I have tried 3 new alternators, 3 new batteries and still getting the issue.

The supply voltage on the hidden qashqai menu when idle shows 13.0v. Should this not be higher around 14.4v as I have a new alternator and battery? When im driving with no additional drain, the suppy voltage fluctuates between 12.6 - 13.2v, and sometimes climbs to 14v for few seconds and back down to 13v.

Does the low idle voltage give a clue what else to check? Many thanks
andy2019
Posts: 1945
Joined: Sat Oct 26, 2019 8:47 pm
Qashqai Model: Mk.2 Qashqai - J11 (2013–2017)

Post by andy2019 »

So you been to nissan had it hooked up to there consult system and they don't know what the problem is eaither ??.
Has the car been set up to detect a new batt has been fitted ...
kavani
Posts: 9
Joined: Fri Nov 24, 2023 4:25 pm
Qashqai Model: Mk.2 Qashqai - J11 (2013–2017)

Post by kavani »

Yes its been to Nissan on multiple occasions and they have hooked up to Consult and it only shows a generic Charging System Error message but no other specific codes they can work off. They have put in 2 genuine alternators and battery's to rule out new-faulty items and I am still getting the same issue.

I assume Nissan have told the ECU a new battery has been fitted though I don't think on the J11 it is necessary...

Any help would be much appreciated!!
Post Reply